Version of llvmlite for scanpy installation?

What version of llvmlite is needed for successful scanpy installation on a Windows 10 machine?

Thanks!

Anything compatible with an up to date version of numba should work, though please open an issue if you run into trouble.

I would note that numba currently does not work with python 3.9, in case that’s what you were running into.

I’m on python 3.9.1, so I thought I’d try an unofficial version of llvmlite.

python - llvmlite failed to install. Error building llvmlite - Stack Overflow

Python Extension Packages for Windows - Christoph Gohlke (uci.edu)

C:\Users\plain>pip show llvmlite
Name: llvmlite
Version: 0.35.0

On attempted scanpy installation I get this error message:

ERROR: Failed building wheel for llvmlite

So I guess the unofficial version of llvmlite is no good for scanpy. I should set up a virtual environment and run an earlier version of python instead?

So I guess the unofficial version of llvmlite is no good for scanpy. I should set up a virtual environment and run an earlier version of python instead?

I think this will be the smoothest path forwards.